Search all categories
Search Offers
Automotive
Baby
Beauty and personal care
Computers & peripherals
Electronics
Fashion
Grocery
Home & living
Musical instruments
Office products
Pet supplies
Sports & outdoors
Tools and home improvement
Toys & games
Video games
Automotive
Baby
Beauty and personal care
Computers & peripherals
Electronics
Fashion
Grocery
Home & living
Musical instruments
Office products
Pet supplies
Sports & outdoors
Tools and home improvement
Toys & games
Video games
CATEGORIES
Deals
Information
Brand List
Terms and Conditions
Privacy Policy
United kingdom
Country
International
United kingdom
UK
Germany
DE
Spain
ES
France
FR
Italy
IT
Ieris
Zyxel GS1900‑10HP PoE+ Gigabit Switch
Zyxel GS1900‑10HP PoE+ Gigabit Switch
Where to buy
Characteristics
This product has not been found in any sponsored store recently, please check similar products from our sponsors or review other stores we offer where you may find the product.
Sponsored
CHECK PRODUCTS/PRICES ON THE WEBSITE
eBay
See Offers
General
Brand
ZYXEL
Model
ZYXEL GS1900-10HP-GB0101F
MPN
ZYXEL GS1900-10HP-GB0101F
Characteristics
10g support
No
Basic switching RJ-45 Ethernet ports quantity
8
Buffer size
525 KB
Certification
CE, FCC, C-Tick, BSMI CNS13438
Console port
RJ-45
Copper ethernet cabling technology
10BASE-T,100BASE-T,1000BASE-T
Depth
104 mm
Form Factor
1U
Heat dissipation
65.472 BTU/h
Height
27 mm
IGMP snooping
Yes
Input current
1.7 A
Input voltage
54 V
Jumbo frames
9000
LED indicators
Yes
MAC address table
8000 entries
Management protocols
SNMP, RMON, ICMP, Syslog
MIB support
RFC 1213, RFC 2819, RFC 1215, RFC 1493
Package depth
227 mm
Package Height
64 mm
Package width
302 mm
Rack mounting
No
Safety
LVD EN60950-1, BSMI CNS14336-1, CB IEC60950-1
Security algorithms
802.1x RADIUS,SSL/TLS
SFP module slots quantity
2
Switch type
Managed
Switching capacity
20 Gbit/s
System event log
Yes
Throughput
14.88 Mpps
Wall mountable
Yes
Web-based management
Yes
Weight
720 g
Width
250 mm
Similar products
Zyxel GS1920-8HPv2 8 Port Smart Switch POE+ silent running free shipping
From
158.85
GBP
7
View Product
Zyxel GS1350-12HP Managed L2 Gigabit Ethernet (10/100/1000) Power over Ethernet (PoE) Grey
From
173.28
GBP
5
View Product
ZYXEL Gs1008-Hp 8 Port Gigabit Poe Unman Desktop Switch 8Xpoe 60W In
From
50.43
GBP
4
View Product
Zyxel XS1930-12HP-ZZ0101F Managed L3 10G Ethernet Network Switch
From
517.68
GBP
2
View Product
Zyxel GS1008HP 8 Port Gigabit Ethernet Switch with Power over Ethernet (PoE)
From
77.99
GBP
1
View Product
Menu
Deals
Categories
Automotive
Baby
Beauty and personal care
Computers & peripherals
Electronics
Fashion
Grocery
Home & living
Musical instruments
Office products
Pet supplies
Sports & outdoors
Tools and home improvement
Toys & games
Video games
Information
Brand List
Terms and Conditions
Privacy Policy
United kingdom
United kingdom
UK
Germany
DE
Spain
ES
France
FR
Italy
IT