Search all categories
Search Offers
Automotive
Baby
Beauty and personal care
Computers & peripherals
Electronics
Fashion
Grocery
Home & living
Musical instruments
Office products
Pet supplies
Sports & outdoors
Tools and home improvement
Toys & games
Video games
Automotive
Baby
Beauty and personal care
Computers & peripherals
Electronics
Fashion
Grocery
Home & living
Musical instruments
Office products
Pet supplies
Sports & outdoors
Tools and home improvement
Toys & games
Video games
CATEGORIES
Deals
Information
Brand List
Terms and Conditions
Privacy Policy
United kingdom
Country
International
United kingdom
UK
Germany
DE
Spain
ES
France
FR
Italy
IT
Ieris
Netgear GS752TSB
Netgear GS752TSB
Where to buy
Characteristics
This product has not been found in any sponsored store recently, please check similar products from our sponsors or review other stores we offer where you may find the product.
Sponsored
CHECK PRODUCTS/PRICES ON THE WEBSITE
eBay
See Offers
General
Brand
NETGEAR
MPN
NETGEAR GS752TSB-100EUS
Characteristics
10g support
No
AC input frequency
50 - 60 Hz
AC input voltage
100 - 240 V
Auto-negotiation
Yes
Auto-sensing
Yes
Bandwidth
56 Gbit/s
Basic switching RJ-45 Ethernet ports quantity
48
Broadcast storm control
Yes
Certification
CE, FCC, VCCI, EN 55022 (CISPR 22), EN 55024 (CISPR 24)
Combo SFP ports quantity
2
Copper ethernet cabling technology
1000BASE-T,100BASE-TX,10BASE-T
Depth
257 mm
DHCP features
DHCP client
Firmware upgradeable
Yes
Flash memory
32 MB
Flow control support
Yes
Full Duplex
Yes
Height
43 mm
IGMP snooping
Yes
Input current
1.4 A
Internal memory
128 MB
LED indicators
Link
Link aggregation
Yes
MAC address table
16000 entries
Management protocols
SNMP v1, v2c, v3
Maximum data transfer rate
1 Gbit/s
Memory type
DDR-SDRAM
MIB support
RFC 1213, RFC 1643, RFC 1493, RFC 2131
Port mirroring
Yes
Power connector
DC-in jack
Power LED
Yes
Rate limiting
Yes
Security algorithms
802.1x RADIUS
SFP module slots quantity
4
SFP/SFP+ slots quantity
6
Spanning Tree Protocol
Yes
SSH/SSL support
Yes
Store-and-forward
Yes
Supported data transfer rates
10/100/1000 Mbps
Switch layer
L3
Switch type
Managed
VLAN support
Yes
Web-based management
Yes
Weight
4.31 kg
Width
440 mm
Similar products
NETGEAR PoE Switch 8 Port Gigabit Ethernet Unmanaged Network Switch (GS108PP) - with 8 x PoE+ @ 123 W Upgradeable, Desktop, Wall Mount or Rackmount, and Limited Lifetime Protection
From
107.71
GBP
2
View Product
Netgear ProSAFE Modular Power Supply Unit 250W AC (APS250W)
From
235.36
GBP
1
View Product
Netgear APS550W-100NES ProSAFE Modular AC Power Supply Adaptor Unit, C14 Connector, 550W Silver
From
418.47
GBP
1
View Product
ProSafe 24 Port Gigabit Managed Switch 10/100/1000 Mbps
From
85.00
GBP
1
View Product
Netgear SFP+ 10GBASE-SR Transceivers (Pack of 10)
From
1,658.31
GBP
1
View Product
Netgear M4300-8X8F 16x10G Managed Switch
From
1,178.62
GBP
1
View Product
Menu
Deals
Categories
Automotive
Baby
Beauty and personal care
Computers & peripherals
Electronics
Fashion
Grocery
Home & living
Musical instruments
Office products
Pet supplies
Sports & outdoors
Tools and home improvement
Toys & games
Video games
Information
Brand List
Terms and Conditions
Privacy Policy
United kingdom
United kingdom
UK
Germany
DE
Spain
ES
France
FR
Italy
IT