Search all categories
Search Offers
Automotive
Baby
Beauty and personal care
Computers & peripherals
Electronics
Fashion
Grocery
Home & living
Musical instruments
Office products
Pet supplies
Sports & outdoors
Tools and home improvement
Toys & games
Video games
Automotive
Baby
Beauty and personal care
Computers & peripherals
Electronics
Fashion
Grocery
Home & living
Musical instruments
Office products
Pet supplies
Sports & outdoors
Tools and home improvement
Toys & games
Video games
CATEGORIES
Deals
Information
Brand List
Terms and Conditions
Privacy Policy
United kingdom
Country
International
United kingdom
UK
Germany
DE
Spain
ES
France
FR
Italy
IT
Ieris
JetStream 16‑Port L2 Managed Gigabit Switch
JetStream 16‑Port L2 Managed Gigabit Switch
Where to buy
Characteristics
This product has not been found in any sponsored store recently, please check similar products from our sponsors or review other stores we offer where you may find the product.
Sponsored
CHECK PRODUCTS/PRICES ON THE WEBSITE
eBay
See Offers
General
Brand
TP-LINK
Model
TP-LINK T2600G-18TS (TL-SG3216)
MPN
TP-LINK T2600G-18TS (TL-SG3216)
Characteristics
10g support
No
AC input frequency
50 - 60 Hz
AC input voltage
100 - 240 V
Auto MDI/MDI-X
Yes
Basic switching RJ-45 Ethernet ports quantity
16
Cables included
AC
Certification
CE, FCC, RoHS
Combo SFP ports quantity
2
Console port
RJ-45
Copper ethernet cabling technology
10BASE-T,100BASE-TX,1000BASE-T
Depth
220 mm
DHCP features
DHCP snooping,DHCP relay,DHCP client
Edition
JetStream
Form factor
Desktop / 1U Rackmount
Forwarding Rate
26.78Mpps
Height
44 mm
IGMP snooping
Yes
Jumbo frames
9216
Jumbo frames support
Yes
LED indicators
Yes
MAC address filtering
Yes
MAC address table
8000 entries
MAC Address Table Size
8K Entries
Management protocols
IGMPv1,IGMPv2,IGMPv3
Manual
Yes
Maximum power consumption
11.47 W
MIB support
RFC1213, RFC2233, RFC1643, RFC1493, RFC2674, RFC2819, RFC2021, RFC2620, RFC2618, RFC2925
Other Non-Network Ports
1 x Micro-USB Console 1 x RJ45 Console
Port mirroring
Yes
Power connector
DC-in jack
Power supply
Internal AC Power Supply
Power supply included
Yes
Security algorithms
802.1x RADIUS,HTTPS,SSH,SSL/TLS
SSH/SSL support
Yes
Switch type
Managed
Switching capacity
36 Gbit/s
Total Network Ports
16 x 10/100/1000 (Gigabit) RJ-45 2 x SFP
Web-based management
Yes
Width
440 mm
Similar products
TP-Link Omada EtherWAN VPN Router with 10G SFP+ Uplink Ports
From
492.92
GBP
4
View Product
TP-Link JetStream 48-Port Gigabit L2 Managed Switch with 4 SFP Slots, L2/L3/L4 QoS and IGMP snooping
From
341.25
GBP
4
View Product
TP-Link Omada EtherWAN VPN Router with 10G SFP+ Uplink Ports
From
920.75
USD
1
View Product
TP-Link TL-SG116E Unmanaged Switch – 16 Port Gigabit RJ45
From
618.13
GBP
1
View Product
Menu
Deals
Categories
Automotive
Baby
Beauty and personal care
Computers & peripherals
Electronics
Fashion
Grocery
Home & living
Musical instruments
Office products
Pet supplies
Sports & outdoors
Tools and home improvement
Toys & games
Video games
Information
Brand List
Terms and Conditions
Privacy Policy
United kingdom
United kingdom
UK
Germany
DE
Spain
ES
France
FR
Italy
IT