NETGEAR GS752TPSB-100EUS Smart Managed Stackable 48 Port PoE + Switch

A 48‑port PoE+ managed switch with 4 SFP slots, 384 W power budget, 10 Gbps uplink bandwidth, L3 routing, QoS, VLANs up to 4093, IGMP snooping a ...
This product has not been found in any sponsored store recently, please check similar products from our sponsors or review other stores we offer where you may find the product.
Other non-sponsored options:
connectixcablingsystems.com
999999.99 USD
Price updated on: 27-08-2025 20:20:59

General

Brand
NETGEAR
MPN
NETGEAR 0713022
Model
NETGEAR GS752TPSB-100EUS

Characteristics

10g support
Yes
AC input frequency
50 - 60 Hz
AC input voltage
100 - 240 V
Bandwidth
104 Gbit/s
Basic switching RJ-45 Ethernet ports quantity
48
Colour
Stainless steel
Copper ethernet cabling technology
1000BASE-T,1000BASE-TX,100BASE-TX,10BASE-T
DHCP features
DHCP client
Ethernet interface type
Fast Ethernet,Gigabit Ethernet
Ethernet LAN data rates
10,100,1000 Mbit/s
Fiber type
Single-mode
Flash memory
32 MB
Gigabit Ethernet copper ports quantity
2
Input current
8 A
Internal memory
128 MB
Latency
20
LED indicators
LAN,PoE,Power,Status
Maximum data transfer rate
10 Gbit/s
Mean time between failures
206539.3 h
Memory type
DDR-SDRAM
MIB support
RFC 1213 MIB II, RFC 1643 Ethernet Interface MIB, RFC 1493 Bridge MIB
Networking standards
IEEE 802.3,IEEE 802.3ab,IEEE 802.3af,IEEE 802.3at,IEEE 802.3az,IEEE 802.3u,IEEE 802.3x,IEEE 802.3z
Operating relative humidity
10 - 90%
Operating temperature
0 - 50 °C
Power consumption
526.8 W
Safety
CE, CUL 60950/EN 60950, CB, CCC
SFP module slots quantity
4
Storage relative humidity
5 - 95%
Storage temperature
-20 - 70 °C
Switch layer
L3
Switch type
Managed
VLANs
4093
Wi-Fi
No
Menu